1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Dev server

Discussion in 'Bug Reports' started by Kelley, Apr 18, 2014.

  1. Kelley
    offline

    Kelley Moderator Staff Member

    Messages:
    377
    Likes Received:
    77
    Trophy Points:
    28
    The tents won't pitch. I see them for a second when I try to pitch them but they are invisible afterwards. The outhouse and the light pole are also invisible. All the locks are working now. However there is a problem adding a lock with the upgrade option. After I upgrade it has 2 doors with 2 locks, I can open one but not the other. So if you try to add a lock you will be locking yourself out. Thanks for all your work, it's looking really good.
     
  2. thevisad
    offline

    thevisad HNGamers - HeadQuarters for all things fun! Staff Member

    Messages:
    499
    Likes Received:
    83
    Trophy Points:
    28
    Thank you sir, I will get right on fixing those items.
     
  3. Kelley
    offline

    Kelley Moderator Staff Member

    Messages:
    377
    Likes Received:
    77
    Trophy Points:
    28
    I'm sorry I didn't really explain that very well. The 2 tents you can craft = when I try to pitch them I go through all the animations of setting up a tent and then I get a message that the tent has been set up but there is no tent. When I try to pitch the regular tent I just get a message, "Wait for the previous action to complete to perform another". These tents were loot drops. I packed up a tent that was already pitched and tried to pitch that but I got the same message.
     
  4. thevisad
    offline

    thevisad HNGamers - HeadQuarters for all things fun! Staff Member

    Messages:
    499
    Likes Received:
    83
    Trophy Points:
    28
    That last message I can replicate (the regular tent one) the others all pitch for me and actually stay. I do know I changed a few of the other files (where the tents used to reside) and reuploaded all of the files. Look at the beta patches and see if the ones there are any different then what you have.
     
  5. Kelley
    offline

    Kelley Moderator Staff Member

    Messages:
    377
    Likes Received:
    77
    Trophy Points:
    28
    This is really odd. The files are all dated correctly and are the exact same size. I downloaded them on 4/18 at 11:58 am pst. Should I swap them out and check again?
     
  6. thevisad
    offline

    thevisad HNGamers - HeadQuarters for all things fun! Staff Member

    Messages:
    499
    Likes Received:
    83
    Trophy Points:
    28
    The only ones of concern should be dayz code equip and weapons. They should all have the same date sometime around 4-18 or so. Code might be newer by a couple of hours or so.
     
  7. Kelley
    offline

    Kelley Moderator Staff Member

    Messages:
    377
    Likes Received:
    77
    Trophy Points:
    28
    The dev server still hasn't restarted. It seems as though that is causing some odd A.I. behavior. Could this be why I'm getting weird test results?
     
  8. thevisad
    offline

    thevisad HNGamers - HeadQuarters for all things fun! Staff Member

    Messages:
    499
    Likes Received:
    83
    Trophy Points:
    28
    I restarted it last night, you should see it up properly now.
     
  9. Kelley
    offline

    Kelley Moderator Staff Member

    Messages:
    377
    Likes Received:
    77
    Trophy Points:
    28
    Thanks, I wasn't sure if the server was causing problems or not. The tents are working for me now. I don't know if the vehicles are supposed to be missing? It seems as though the static triggers are stuck? I triggered one at the north airport a couple of hours ago and it is still activated. Are they going to stay activated until restart now? I think I like it better when they stay activated longer, seems more realistic.
     
  10. thevisad
    offline

    thevisad HNGamers - HeadQuarters for all things fun! Staff Member

    Messages:
    499
    Likes Received:
    83
    Trophy Points:
    28
    Hmmm, I will check on the static triggers, I know one of the last changes to the Ai system made some pretty drastic changes. I did not think they stayed activated though and shut off after 10 minutes I believe. One of the things I had done trying to sort out the loot bug was to eliminate anything that spawned on the server (buildings/vehicles/ai), I might have missed a // somewhere which turned em off.
     
  11. Kelley
    offline

    Kelley Moderator Staff Member

    Messages:
    377
    Likes Received:
    77
    Trophy Points:
    28
    That gives me a headache just thinking about it.
     
  12. thevisad
    offline

    thevisad HNGamers - HeadQuarters for all things fun! Staff Member

    Messages:
    499
    Likes Received:
    83
    Trophy Points:
    28
    Lol, you have no idea man
     
  13. thevisad
    offline

    thevisad HNGamers - HeadQuarters for all things fun! Staff Member

    Messages:
    499
    Likes Received:
    83
    Trophy Points:
    28
    FYI we are now down to verifying everything works properly in the hive. Tents and such are pitching correctly and going into the hive, but they are not spawning back onto the server. This is the last of it, all patching has been done and unless I find something client side we are done. Most of this is all server side stuff that needs to be addressed.
     
  14. Kelley
    offline

    Kelley Moderator Staff Member

    Messages:
    377
    Likes Received:
    77
    Trophy Points:
    28
    Thanks for the info, I can feel my sanity returning already. ( my wife thanks you too).
     
  15. McKeighan
    offline

    McKeighan New Member

    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1

    Tents are still hozed.


    I think you might find that the issue is the tents are not exempt from the server_cleanup.fsm I've noticed that player corpses disappear rather fast as well - again, same place, same basic issue with the cleanup script.
     
  16. Kelley
    offline

    Kelley Moderator Staff Member

    Messages:
    377
    Likes Received:
    77
    Trophy Points:
    28
    Thanks for your feedback McKeigan. This post from May is way outdated though.Lots of new content has been added. I think Thevisad has this fixed but the server hasn't been patched yet.
     
  17. McKeighan
    offline

    McKeighan New Member

    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    While new content may be added, tents for SURE aren't making it past the server cleanup function. Morak placed one last night, and within 3 seconds, it poofed.
     
  18. Kelley
    offline

    Kelley Moderator Staff Member

    Messages:
    377
    Likes Received:
    77
    Trophy Points:
    28
    Yes, on this current patch tents are not working correctly. The tents are going " poof" but return on restart and stay. They hold gear also. There is also a tent in the loot spawn that shouldn't be there.
     
  19. McKeighan
    offline

    McKeighan New Member

    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    I just noticed that.... the tent that he placed last night is there now.
     
  20. thevisad
    offline

    thevisad HNGamers - HeadQuarters for all things fun! Staff Member

    Messages:
    499
    Likes Received:
    83
    Trophy Points:
    28
    I don't understand why that is happening, nothing in the code is telling the tent to poof itself. It apparently affects any buildings, 1 at a time.
     

Share This Page